import re
regex = re.compile(r"(^=+\s?|\s?=+=\s?)")
test_str = ("====== tOTO ===\n"
" Toto \n"
"====== tOTO ==== \n\n"
"== tOTO =\n"
"asdf\n"
"sDF\n"
"ASDF")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)