re = /(^=+\s?|\s?=+=\s?)/
str = '====== tOTO ===
Toto
====== tOTO ====
== tOTO =
asdf
sDF
ASDF'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result