using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/[a-z]+(-[a-z]+)*(\/|$)";
string input = @"/zh/
/zh
/zh-en
/zh-en/
/zh-en-en/
/zh-en-en/123123/123
/zh/123123/123
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}