$re = '/\/[a-z]+(-[a-z]+)*(\/|$)/mi';
$str = '/zh/
/zh
/zh-en
/zh-en/
/zh-en-en/
/zh-en-en/123123/123
/zh/123123/123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);