// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\/[a-z]+(-[a-z]+)*(\/|$)").unwrap();
let string = "/zh/
/zh
/zh-en
/zh-en/
/zh-en-en/
/zh-en-en/123123/123
/zh/123123/123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}