re = /\/[a-z]+(-[a-z]+)*(\/|$)/mi
str = '/zh/
/zh
/zh-en
/zh-en/
/zh-en-en/
/zh-en-en/123123/123
/zh/123123/123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end