# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w*)(?|\$(\w+)|\$`([^\n`]*)`)/\1[["\2"]]/gm;t' <<< "qux$foo$bar
qux$foo$bar; input$test$a$a
qux[[\"foo\"]][[\"bar\"]]; input[[\"test\"]][[\"a\"]][[\"a\"]]
qux$`foo`; bar$`baz`; x$uvw
qux[[\"foo\"]]; bar[[\"baz\"]]; x[[\"uvw\"]]
qux$`fo o`"