import Foundation
let pattern = #"(\w*)(?|\$(\w+)|\$`([^\n`]*)`)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
qux$foo$bar
qux$foo$bar; input$test$a$a
qux[["foo"]][["bar"]]; input[["test"]][["a"]][["a"]]
qux$`foo`; bar$`baz`; x$uvw
qux[["foo"]]; bar[["baz"]]; x[["uvw"]]
qux$`fo o`
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1[["\2"]]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)