const regex = /(\w*)(?|\$(\w+)|\$`([^\n`]*)`)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*)(?|\\$(\\w+)|\\$`([^\\n`]*)`)', 'gm')
const str = `qux\$foo\$bar
qux\$foo\$bar; input\$test\$a\$a
qux[["foo"]][["bar"]]; input[["test"]][["a"]][["a"]]
qux\$\`foo\`; bar\$\`baz\`; x\$uvw
qux[["foo"]]; bar[["baz"]]; x[["uvw"]]
qux\$\`fo o\``;
const subst = `\1[["\2"]]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);