re = /(\w*)(?|\$(\w+)|\$`([^\n`]*)`)/m
str = 'qux$foo$bar
qux$foo$bar; input$test$a$a
qux[["foo"]][["bar"]]; input[["test"]][["a"]][["a"]]
qux$`foo`; bar$`baz`; x$uvw
qux[["foo"]]; bar[["baz"]]; x[["uvw"]]
qux$`fo o`'
subst = '\\1[["\\2"]]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result