import re
regex = re.compile(r"^(\+[0-9]{1,2})?(\.|\ |\-)?([0-9]{1,3}(\.|\ |\-)?){5,6}$", flags=re.MULTILINE)
test_str = ("0084966713061\n"
"84966713061\n"
"09661331313\n"
"123456\n"
"+33.434.34.34.34\n"
"01 23 45 67 89\n"
"+33 1 23 45 67 89\n"
"+33.1.23.45.67.89\n"
"+1.234.234.356.1213:2324\n"
"abdfaksdf\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")