re = /^(\+[0-9]{1,2})?(\.|\ |\-)?([0-9]{1,3}(\.|\ |\-)?){5,6}$/m
str = '0084966713061
84966713061
09661331313
123456
+33.434.34.34.34
01 23 45 67 89
+33 1 23 45 67 89
+33.1.23.45.67.89
+1.234.234.356.1213:2324
abdfaksdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end