re = /"ms_played":\s"(\d*)"/m
str = '"somedata", "ms_played": "0815", "somedata"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end