package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(\.\d+)?)\s(SAR|USD)`)
var str = `Amount: 0.99 USD , 02:04:2021
Amount: 73 SAR , 02:04:2021
Amount: 133 SAR , 02:04:2021
Amount: 100 SAR , 02:04:2021
Amount: 101 SAR , 02:04:2021
Amount: 6 SAR , 02:04:2021
Amount: 104 SAR , 02:04:2021
Amount: 57 SAR , 02:04:2021
Amount: 61 SAR , 02:04:2021
Amount: 12 SAR , 02:04:2021
Amount: 12888.9 SAR , 02:04:2021
Amount: 144 SAR , 02:04:2021
Amount: 75 SAR , 02:04:2021
Amount: 904 SAR , 02:04:2021
Amount: 13.99 USD , 02:04:2021
Amount: 90 SAR , 02:04:2021
Amount: 10 USD , 02:04:2021
Amount: 106 SAR , 02:04:2021
Amount: 66 SAR , 02:04:2021
Amount: 508 SAR , 02:04:2021
Amount: 21.95 SAR , 02:04:2021`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}