# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+(\.\d+)?)\s(SAR|USD)"
test_str = ("Amount: 0.99 USD , 02:04:2021 \n"
"Amount: 73 SAR , 02:04:2021 \n"
"Amount: 133 SAR , 02:04:2021 \n"
"Amount: 100 SAR , 02:04:2021 \n"
"Amount: 101 SAR , 02:04:2021 \n"
"Amount: 6 SAR , 02:04:2021 \n"
"Amount: 104 SAR , 02:04:2021 \n"
"Amount: 57 SAR , 02:04:2021 \n"
"Amount: 61 SAR , 02:04:2021 \n"
"Amount: 12 SAR , 02:04:2021 \n"
"Amount: 12888.9 SAR , 02:04:2021 \n"
"Amount: 144 SAR , 02:04:2021 \n"
"Amount: 75 SAR , 02:04:2021 \n"
"Amount: 904 SAR , 02:04:2021 \n"
"Amount: 13.99 USD , 02:04:2021 \n"
"Amount: 90 SAR , 02:04:2021 \n"
"Amount: 10 USD , 02:04:2021 \n"
"Amount: 106 SAR , 02:04:2021 \n"
"Amount: 66 SAR , 02:04:2021 \n"
"Amount: 508 SAR , 02:04:2021 \n"
"Amount: 21.95 SAR , 02:04:2021")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.