use strict;
my $str = 'Amount: 0.99 USD , 02:04:2021
Amount: 73 SAR , 02:04:2021
Amount: 133 SAR , 02:04:2021
Amount: 100 SAR , 02:04:2021
Amount: 101 SAR , 02:04:2021
Amount: 6 SAR , 02:04:2021
Amount: 104 SAR , 02:04:2021
Amount: 57 SAR , 02:04:2021
Amount: 61 SAR , 02:04:2021
Amount: 12 SAR , 02:04:2021
Amount: 12888.9 SAR , 02:04:2021
Amount: 144 SAR , 02:04:2021
Amount: 75 SAR , 02:04:2021
Amount: 904 SAR , 02:04:2021
Amount: 13.99 USD , 02:04:2021
Amount: 90 SAR , 02:04:2021
Amount: 10 USD , 02:04:2021
Amount: 106 SAR , 02:04:2021
Amount: 66 SAR , 02:04:2021
Amount: 508 SAR , 02:04:2021
Amount: 21.95 SAR , 02:04:2021';
my $regex = qr/(\d+(\.\d+)?)\s(SAR|USD)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}