import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(\\.\\d+)?)\\s(SAR|USD)";
final String string = "Amount: 0.99 USD , 02:04:2021 \n"
+ "Amount: 73 SAR , 02:04:2021 \n"
+ "Amount: 133 SAR , 02:04:2021 \n"
+ "Amount: 100 SAR , 02:04:2021 \n"
+ "Amount: 101 SAR , 02:04:2021 \n"
+ "Amount: 6 SAR , 02:04:2021 \n"
+ "Amount: 104 SAR , 02:04:2021 \n"
+ "Amount: 57 SAR , 02:04:2021 \n"
+ "Amount: 61 SAR , 02:04:2021 \n"
+ "Amount: 12 SAR , 02:04:2021 \n"
+ "Amount: 12888.9 SAR , 02:04:2021 \n"
+ "Amount: 144 SAR , 02:04:2021 \n"
+ "Amount: 75 SAR , 02:04:2021 \n"
+ "Amount: 904 SAR , 02:04:2021 \n"
+ "Amount: 13.99 USD , 02:04:2021 \n"
+ "Amount: 90 SAR , 02:04:2021 \n"
+ "Amount: 10 USD , 02:04:2021 \n"
+ "Amount: 106 SAR , 02:04:2021 \n"
+ "Amount: 66 SAR , 02:04:2021 \n"
+ "Amount: 508 SAR , 02:04:2021 \n"
+ "Amount: 21.95 SAR , 02:04:2021";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}