# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[\\\\/]?|[\\\\/]+|(?<![\\\\/])[\\\\/]?$/\//mg;t' <<< "
path
/path
\path
path/
path\
/path/
\path\
path/path2
path\path2"