#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[\\\/]?|[\\\/]+|(?<![\\\/])[\\\/]?$"
Local $sString = "" & @CRLF & _
"path" & @CRLF & _
"/path" & @CRLF & _
"\path" & @CRLF & _
"path/" & @CRLF & _
"path\" & @CRLF & _
"/path/" & @CRLF & _
"\path\" & @CRLF & _
"path/path2" & @CRLF & _
"path\path2"
Local $sSubst = "/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)