re = /^[\\\/]?|[\\\/]+|(?<![\\\/])[\\\/]?$/m
str = '
path
/path
\\path
path/
path\\
/path/
\\path\\
path/path2
path\\path2'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result