use strict;
my $str = '
path
/path
\\path
path/
path\\
/path/
\\path\\
path/path2
path\\path2';
my $regex = qr`^[\\\/]?|[\\\/]+|(?<![\\\/])[\\\/]?$`mp;
my $subst = '/';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";