#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+?)(?:\.\[(\d{4}\-\d{4}\s|\d{4}\-\d{4}|\d{4}\-\s|\d{4}\s|\d{4})([^\]]*)\])(?:\.(.+))?$|^(.+)(?:\.(.+))$"
Local $sString = "Dr. STONE.[2019-2022 Crunchyroll].Manga" & @CRLF & _
"Dr. STONE.Manga" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")