re = /^(.+?)(?:\.\[(\d{4}\-\d{4}\s|\d{4}\-\d{4}|\d{4}\-\s|\d{4}\s|\d{4})([^\]]*)\])(?:\.(.+))?$|^(.+)(?:\.(.+))$/m
str = 'Dr. STONE.[2019-2022 Crunchyroll].Manga
Dr. STONE.Manga
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end