$re = '/^(.+?)(?:\.\[(\d{4}\-\d{4}\s|\d{4}\-\d{4}|\d{4}\-\s|\d{4}\s|\d{4})([^\]]*)\])(?:\.(.+))?$|^(.+)(?:\.(.+))$/m';
$str = 'Dr. STONE.[2019-2022 Crunchyroll].Manga
Dr. STONE.Manga
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);