package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?)(?:\.\[(\d{4}\-\d{4}\s|\d{4}\-\d{4}|\d{4}\-\s|\d{4}\s|\d{4})([^\]]*)\])(?:\.(.+))?$|^(.+)(?:\.(.+))$`)
var str = `Dr. STONE.[2019-2022 Crunchyroll].Manga
Dr. STONE.Manga
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}