#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:http[s]?:\/\/)?(?:www\.)?([\w+\.]+)"
Local $sString = "https://www.autoitscript.com.tr/" & @CRLF & _
"www.autoitscript.de" & @CRLF & _
"http://www.autoitscript.co.uk" & @CRLF & _
"http://autoitscript.tr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")