re = /(?:http[s]?:\/\/)?(?:www\.)?([\w+\.]+)/
str = 'https://www.autoitscript.com.tr/
www.autoitscript.de
http://www.autoitscript.co.uk
http://autoitscript.tr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end