using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http[s]?:\/\/)?(?:www\.)?([\w+\.]+)";
string input = @"https://www.autoitscript.com.tr/
www.autoitscript.de
http://www.autoitscript.co.uk
http://autoitscript.tr";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}