$re = '/(?:http[s]?:\/\/)?(?:www\.)?([\w+\.]+)/';
$str = 'https://www.autoitscript.com.tr/
www.autoitscript.de
http://www.autoitscript.co.uk
http://autoitscript.tr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);