use strict;
my $str = 'foo)bar)baz STRING foo)bar)baz)';
my $regex = qr/((?:\G(?!^)|STRING).*?)\)/mp;
my $subst = '$1)add-something-here...';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";