import Foundation
let pattern = #"((?:\G(?!^)|STRING).*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"foo)bar)baz STRING foo)bar)baz)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1)add-something-here..."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)