re = /((?:\G(?!^)|STRING).*?)\)/m
str = 'foo)bar)baz STRING foo)bar)baz)'
subst = '$1)add-something-here...'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result