import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^01[3,4,5,6,7,8,9]\\d{8}";
final String string = "01301234567\n"
+ "01401234589\n"
+ "01501234567\n"
+ "01601234589\n"
+ "01701234589\n"
+ "01801234567\n"
+ "01901234589";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}