$re = '/^01[3,4,5,6,7,8,9]\d{8}/m';
$str = '01301234567
01401234589
01501234567
01601234589
01701234589
01801234567
01901234589';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);