// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^01[3,4,5,6,7,8,9]\d{8}").unwrap();
let string = "01301234567
01401234589
01501234567
01601234589
01701234589
01801234567
01901234589";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}