import re
regex = re.compile(r"^01[3,4,5,6,7,8,9]\d{8}", flags=re.MULTILINE)
test_str = ("01301234567\n"
"01401234589\n"
"01501234567\n"
"01601234589\n"
"01701234589\n"
"01801234567\n"
"01901234589")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")