#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\d+\..*?Dogru cevap.*?$"
Local $sString = "random text" & @CRLF & _
"2. problem" & @CRLF & _
"text" & @CRLF & _
"more text" & @CRLF & _
"Dogru cevap: A" & @CRLF & _
"even more text" & @CRLF & _
"3. problem" & @CRLF & _
"text" & @CRLF & _
"more text" & @CRLF & _
"Dogru cevap: A" & @CRLF & _
"more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")