const regex = /\d+\..*?Dogru cevap.*?$/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\..*?Dogru cevap.*?$', 'gms')
const str = `random text
2. problem
text
more text
Dogru cevap: A
even more text
3. problem
text
more text
Dogru cevap: A
more text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}