import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\..*?Dogru cevap.*?$";
final String string = "random text\n"
+ "2. problem\n"
+ "text\n"
+ "more text\n"
+ "Dogru cevap: A\n"
+ "even more text\n"
+ "3. problem\n"
+ "text\n"
+ "more text\n"
+ "Dogru cevap: A\n"
+ "more text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}