$re = '/\d+\..*?Dogru cevap.*?$/ms';
$str = 'random text
2. problem
text
more text
Dogru cevap: A
even more text
3. problem
text
more text
Dogru cevap: A
more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);