using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([0-9][,]?[])([0-9][?=\ ]?[В]?[Вт]))";
string input = @"SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}