// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([0-9][,]?[])([0-9][?=\ ]?[В]?[Вт]))").unwrap();
let string = "SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}