$re = '/(([0-9][,]?[])([0-9][?=\ ]?[В]?[Вт]))/m';
$str = 'SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);