import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-9][,]?[])([0-9][?=\\ ]?[В]?[Вт]))";
final String string = "SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF\n"
+ "SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF\n\n"
+ "SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX\n"
+ "SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}