const regex = /(\/\d\d){4}\/\d{10}_\d\d__\d\d\..../gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\d\\d){4}\\\/\\d{10}_\\d\\d__\\d\\d\\....', 'gm')
const str = `ftp://111.111.111.11/09/61/99/37/0961993761.spx
ftp://111.111.111.11/09/61/99/37/0961993761_00__00.spx
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}