use strict;
my $str = 'ftp://111.111.111.11/09/61/99/37/0961993761.spx
ftp://111.111.111.11/09/61/99/37/0961993761_00__00.spx
';
my $regex = qr/(\/\d\d){4}\/\d{10}_\d\d__\d\d\..../mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}