import re
regex = re.compile(r"(\/\d\d){4}\/\d{10}_\d\d__\d\d\....", flags=re.MULTILINE)
test_str = ("ftp://111.111.111.11/09/61/99/37/0961993761.spx\n"
"ftp://111.111.111.11/09/61/99/37/0961993761_00__00.spx\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")