import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\s]+)?(var|let|const)?([\\s]+)?([a-z=\\s]+)(\\()(.+)?(\\))([\\s]+)?([\\n]+)?(\\{)";
final String string = "function func (foo) {}\n\n"
+ "var func = function() {}\n\n"
+ "function func () {\n"
+ "}\n\n"
+ "var func = function() {\n"
+ "}\n\n"
+ "function func ()\n"
+ "{\n"
+ "}\n\n"
+ "var func = function()\n"
+ "{\n"
+ "}\n\n\n\n"
+ "function func () {}\n\n"
+ "var func = function() {}\n\n"
+ "function func () {\n"
+ "}\n\n"
+ "var func = function() {\n"
+ "}\n\n"
+ "function func () \n"
+ "{\n"
+ "}\n\n"
+ "var func = function() \n"
+ "{\n"
+ "}\n\n\n\n"
+ " function func () {}\n\n"
+ " var func = function() {}\n\n"
+ " function func () {\n"
+ "}\n\n"
+ " var func = function() {\n"
+ "}\n\n"
+ " function func () \n"
+ "{\n"
+ "}\n\n"
+ " var func = function() \n"
+ "{\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}