package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Volume{(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)}`)
var str = `Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}
\\\\?\\Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}\\
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}