import re
regex = re.compile(r"Volume{(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)}", flags=re.MULTILINE)
test_str = ("Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}\n"
"\\\\\\\\?\\\\Volume{db41aa6a-c0b8-11e9-bc8a-806e6f6e6963}\\\\\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")